Cambridge Payments: Degraded performance detected

Incident Report for Beanworks

Monitoring

A fix has been deployed by the provider to address the earlier degradation in service.
Posted Jul 11, 2025 - 13:49 PDT

Investigating

Cambridge is currently experiencing intermittent payment failures across all three services. They are currently investigating the issue. Please reach out to Quadient AP Support if you are affected by this.
Posted Jul 11, 2025 - 10:59 PDT
This incident affects: Payment Provider (Cambridge).